bootstrap 兼容IE9 IE10 IE11的解决办法

最近用bootstrap做wordpress主题,发现IE11下,主题界面混乱的一塌糊涂,好像没有加载css样式一样。

解决办法如下:

针对IE9及以下的浏览器,在header中插入:

不要用file://或@import形式引用respond.min.js或respond.js或css文件

bootstrap不支持IE兼容模式,为了让IE浏览器运行最新的渲染模式,将添加以下标签在页面中

IE=edge表示强制使用IE最新内核,chrome=1表示如果安装了针对IE6/7/8等版本的浏览器插件Google Chrome Frame(可以让用户的浏览器外观依然是IE的菜单和界面,但用户在浏览网页时,实际上使用的是Chrome浏览器内核),那么就用Chrome内核来渲染。

然后再加一句:

JS与CSS的引入顺序导致的问题
必须先引用css在引用js

以上问题解决之后,bootstrap3兼容IE没有太大问题。

本站提供的服务

  • wordpress主题、插件、开发、优化以及WordPress虚拟主机、VPS售卖
  • 自用Shadowsocks 服务器搭建 RMB50/次
  • VPN(PPTP&L2TP)流量出售: 5RMB/GB,10GB起售,8条台湾、美国、香港线路
    • 联系QQ:2564692806

      打赏作者
      这篇文章帮助很大,重重有赏

      您的支持将鼓励我们继续创作!

      [微信] 扫描二维码打赏

      [支付宝] 扫描二维码打赏

      正在跳转到PayPal...

Add a Comment

电子邮件地址不会被公开。 必填项已用*标注